"Unable to connect to 'http(s)://<SERVER_NAME>:<PORT>/CAisd/UploadServlet/'" when uploading a file or URL
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"Unable to connect to 'http(s)://<SERVER_NAME>:<PORT>/CAisd/UploadServlet/'" when uploading a file or URL

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Article ID: 45478

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Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

When attempting to upload a file or URL with any role it fails with the following error:

"Unable to connect to 'http(s)://<SERVER_NAME>:<PORT>/CAisd/UploadServlet/'.  Please make sure that the servlet server is correct, and that Tomcat is up and running. Would you like to retry?"

Environment

17.x

Cause

The Servlet path is incorrect. It contains an extra forward slash which prevents to upload the file or add URLs:

http(s)://<SERVER_NAME>:<PORT>/CAisd/UploadServlet/

The correct URL should be without the last forward slash:

http(s)://<SERVER_NAME>:<PORT>/CAisd/UploadServlet

Resolution

Edit the servlet path URL by removing the last forward slash, this will allow the server to use the servlet path without issue.

1. Log in Service Desk with an administrator account.

2. Go to the administration tab-> System -> Servers.

3. Click on the server which you need to edit the servlet path and then modify correctly the value. No restarts are required. 

Additional Information

Another possible cause is that the server_name and/or domain is/are incorrect in the servlet path.