サードパーティ製バックアップでスナップショットファイルの統合に失敗する
search cancel

サードパーティ製バックアップでスナップショットファイルの統合に失敗する

book

Article ID: 454720

calendar_today

Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

免責事項:これは英文の記事「Third party backup fail to consolidate snapshot files」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

  • サードパーティ製のバックアップで、スナップショットファイルの統合に失敗します。
  • バックアップ自体は正常に完了しますが、ファイルのロックが原因で統合が正しく実行されません。
  • ESXiホスト上で vmkernel ログ(/var/run/log/vmkernel.log)を確認すると、以下のような競合エラーが記録されています:

    yyyy-mm-ddThh:mm.ss.xxxZ In(182) vmkernel: cpu6:2110410)FSS: 6835: Conflict between buffered and unbuffered open (file 'vmname-flat.vmdk'):flags 0x4002, requested flags 0x8
    yyyy-mm-ddThh:mm.ss.xxxZ In(182) vmkernel: cpu6:2110410)FSS: 6835: Conflict between buffered and unbuffered open (file 'vmname-flat.vmdk'):flags 0x4002, requested flags 0x8
    yyyy-mm-ddThh:mm.ss.xxxZ In(182) vmkernel: cpu6:2110410)FSS: 6835: Conflict between buffered and unbuffered open (file 'vmname-flat.vmdk'):flags 0x4002, requested flags 0x8
    yyyy-mm-ddThh:mm.ss.xxxZ In(182) vmkernel: cpu6:2110410)FSS: 6835: Conflict between buffered and unbuffered open (file 'vmname-flat.vmdk'):flags 0x4002, requested flags 0x8

  • hostd.log (/var/run/log/hostd.log)には、以下のようなファイルロックに関するエラーが記録されています:

    yyyy-mm-ddThh:mm.ss.xxxZ Db(167) Hostd[2100508]: [Originator@6876 sub=Vigor.Vmsvc.vm:/vmfs/volumes/datastore/vmname/vmname.vmx] Consolidate Disks message: An error occurred while consolidating disks: Failed to lock the file.
    yyyy-mm-ddThh:mm.ss.xxxZ Db(167) Hostd[2100133]: --> Locking conflict for file "/vmfs/volumes/datastore/vmname/vmname-flat.vmdk". VMFS on-disk lock owner is host with MAC address xxxxxxxx-xxxxxxxx-xxxx-xxxxxxxxxxxx and VMFS lock mode 0x2.
    yyyy-mm-ddThh:mm.ss.xxxZ Db(167) Hostd[2100133]: --> Locking conflict for file "/vmfs/volumes/datastore/vmname/vmname-flat.vmdk". Kernel open flags are 0x4002. Owner process on this host is world ID 2110410 with world name vmx-vcpu-0:vmname.
    yyyy-mm-ddThh:mm.ss.xxxZ Db(167) Hostd[2100133]: --> Consolidation failed for disk node 'scsi0:1': Failed to lock the file.
    yyyy-mm-ddThh:mm.ss.xxxZ Db(167) Hostd[2100133]: -->

Environment

vSphere 7.x
vSphere 8.x

Cause

この問題は、サードパーティ製ソフトウェアとの相互作用に起因しています。通常、バックアップソフトウェアがアクティブなディスクセッションを不適切に保持し続けている場合や、親仮想ディスクに対してロックされているプロキシのホットアドセッションを解放できない場合に発生します。

Resolution

サードパーティ製のバックアップサーバー、または関連する特定のバックアップサービスを再起動し、ロックされているファイルセッションを強制的に解放します。