vCenter upgrade from 8.0 to 9.1 fails with "Failed to register lookupsvc-syaas with lookupsvc"
search cancel

vCenter upgrade from 8.0 to 9.1 fails with "Failed to register lookupsvc-syaas with lookupsvc"

book

Article ID: 454674

calendar_today

Updated On:

Products

VMware vCenter Server 8.0

Issue/Introduction

An error may appear in the GUI.

Encountered an internal error.  Traceback (most recent call last):   File "/usr/lib/vmidentity/firstboot/vmidentity-firstboot.py", line 1054, in main     vmidentityFB.invokeLookupsvcSyaaSServiceRegistartion(str(uuid.uuid4()), LOOKUPSVCSYAAS_SPEF_FILE_PATH)   File "/usr/lib/vmidentity/firstboot/vmidentity-firstboot.py", line 427, in invokeLookupsvcSyaaSServiceRegistartion     ErrorHandler.raise_error("Failed to register lookupsvc-syaas with lookupsvc", command, rc, stdout, stderr)   File "/usr/lib/vmidentity/firstboot/vmidentity-firstboot.py", line 1038, in raise_error     raise RuntimeError(msg) RuntimeError: Failed to register lookupsvc-syaas with lookupsvc ', args=['Traceback (most recent call last):   File "/usr/lib/vmidentity/firstboot/vmidentity-firstboot.py", line 1054, in main     

 

This error is observed in the lookupsvc log.

2026-08-06T12:27:46.331Z INFO lookupsvc 82 [vc@4413 threadName="pool-2-thread-3" logger="com.vmware.vim.lookup.vlsi.VlsiSecurityChecker"] Operation create is not permitted for user {Name: Administrator, Domain: VSPHERE.LOCAL}

Environment

vCenter 8.0 U3

Cause

The Administrator account has been removed from the Administrators group in the vCenter SSO domain (default name vsphere.local).

Resolution

Add the Administrator account back into the Administrators group.

-Any users from the Administrators group members list can be use to login and add Administrator to the Administrators group using the UI
Add Members to a vCenter Single Sign-On Group
https://techdocs.broadcom.com/us/en/vmware-cis/vsphere/vsphere/8-0/vsphere-authentication/vsphere-authentication-with-vcenter-single-sign-on/managing-users-and-groups-with-sso/add-members-to-a-vcenter-single-sign-on-group.html