cmsso-util break-elm utility fails with "java.net.URI.getHost()" is null
search cancel

cmsso-util break-elm utility fails with "java.net.URI.getHost()" is null

book

Article ID: 454669

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

cmsso-util break-elm --mode execute on the Management vCenter and it fails with -  Cannot invoke "String.equalsIgnoreCase(String)" because the return value of "java.net.URI.getHost()" is null

Environment

vCenter 9.1.0.0300

vSLR 9.0.2

Cause

malformed SRM service registration that comes with VLSR 9.0.2.

lookup service logs (lookupserver-default.log):  

2026-08-24T17:57:21.470Z WARNING lookupsvc 95 [vc@4413 threadName="pool-2-thread-14" logger="com.vmware.vim.lookup.impl.LdapStorage" ] Failed to get endpoint host for ***. java.lang.IllegalArgumentException: URI is not absolute 
2026-08-24T17:57:21.470Z WARNING lookupsvc 95 [vc@4413 threadName="pool-2-thread-14" logger="com.vmware.vim.lookup.impl.LdapStorage" ] Failed to get endpoint host for ***. java.lang.IllegalArgumentException: URI is not absolute  

service registration its talking about:    

 Service Product: com.vmware.dr
 Service Type: dpxa
Service ID: ########-####-####-####-############
 Site ID: default-first-site
 Owner ID: dpxa-########-####-####-####-############@vsphere.local
 Version: 9.0.2.24639340
 Endpoints:
  Type: com.vmware.dr.dpxa
  Protocol: rest
  URL: *** <----------
 Attributes:
 vcService: ########-####-####-####-############
 srmService: ########-####-####-####-############
  domainType:
  domainName: vsphere.local
  isActive: false
 domainId: ########-####-####-####-############

Resolution

Either upgrade vSLR from 9.0.2 to 9.0.3 or remove it before breaking ELM and then reinstall vSLR 9.1.x