During the deployment of additional workload domains the Validate Backup Location subtask fails with Message: Invalid parameter: Validation failed for directory path.
The domain manager log will have an error stating: "Make sure the backup directory is intact and sftp server has write permissions on backup path."
Attempt a connection and manually perform the test from the CLI as root:
sftp -vvv [email protected]pwd ls -lacd <path-to-test>pwdmkdir vcf-testls -larmdir vcf_test
SDDC 5.x
A failure to connect would indicate a problem with your ssh keys in the known_hosts files. SDDC Manager validation is failing because it does not trust the SSH host key being presented by the sftp server.
A failure in executing commands after the connection would indicate an sftp server-side issue.
For a failure to connect you will need to validate your ssh keys configured in the known_hosts files on the SDDC Manager - See Creating a new Workload domain on SDDC manager fails when trying to validate Backup Location Details
For any other failure after the sftp connection has been established you will need to remediate the sftp server side configuration issues.