重複 IP アドレスの競合により NSX ホストの準備または再接続が失敗する
search cancel

重複 IP アドレスの競合により NSX ホストの準備または再接続が失敗する

book

Article ID: 454545

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

免責事項:これは英文の記事「Duplicate TEP IP Address Conflict During VCF ESXi Host Commissioning」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

障害が発生したホストの再接続や、新しいトランスポート ノードの準備を NSX 上で試みると、操作が失敗します。
NSX Manager の UI またはログに、以下のようなエラーが報告される場合があります。

  • Error: Credentials for host need to be specified. (Error code: 26208)
  • 26210: Node <Node-ID> with same ip <IP-Address> already exists. Check the state of existing transport node.

Syslog エラー (nsx-manager /var/log/proton/nsxapi.log):

  • desiredStateErrorMessage = 26210: Node <Node-ID>... with same ip 192.##.##.## already exists. Check the state of existing transport node. If it is a failure in deletion then use force option to delete previous transport node and retry the operation.

Environment

NSX 4.x

Cause

この問題は、管理ネットワーク上での IP アドレスの重複によって発生します。他のデバイスが ESXi ホストと同じ IP アドレスを共有していることで、ARP(Address Resolution Protocol)の競合が発生します。

Resolution

  1. ESXi ホストの CLI で /var/log/vobd.log を確認し、重複 IP の検知状況を確認します。
  2. 以下のようなログ エントリーを探します。
    [vob.net.ip.duplicate] Duplicate IP address detected for 10.10.##.## on interface vmk#, current owner being 00:50:56:##:##:##.
  3. vSphere Client を使用して、ログで特定された MAC アドレスを検索し、競合している仮想マシン、ホスト、またはインターフェイスを特定します。
  4. ネットワーク上の IP 競合を解消し、該当の ESXi ホストに対して管理 IP アドレスが一意になるように設定します。

Additional Information

NSX Host Preparation or Reconnection fails due to Duplicate IP Address Conflict