Validation fails during domain sync or import domain workflow with the error:
"The vCenter Server virtual machine is not connected to a distributed virtual port group"
VMware Cloud Foundation 9.x
This issue occurs when multiple Distributed Virtual Switches (DVS) in the SDDC Manager database share the same source_id, causing validation to target the incorrect DVS.
This issue will be fixed in VCF 9.1.1
Validate duplicate source_ids:
source_id entries exist:psql -h localhost -U postgres -d platform -c "select source_id,id from vds"Example of an output with duplicate VDS source_ids source_id | id
-----------+--------------------------------------
dvs-19 | 821abbb3-2ba0-47eb-a7e4-aea6607120cb
dvs-19 | dff02e60-96d7-45c2-91dd-2b10a85d61f9
Workaround:
echo "vcf.import.guardrails.vcenter.vm.dvpg.skip=true" >> /etc/vmware/vcf/operationsmanager/application-prod.properties
systemctl restart operationsmanagercurl localhost/operationsmanager/about{"id":"a17d507f-d7bb-405d-af2f-09cc04d61cb5","name":"OPERATIONS_MANAGER","version":"9.1.0.0.25371089","status":"ACTIVE","serviceUrl":"http://localhost/operationsmanager","description":"Operations Manager"}