Applying Host Profiles with vSAN configuration changes fails with Batch remediation failed on all target hosts with 'ClusterUUID' MethodFault in Host Profiles
search cancel

Applying Host Profiles with vSAN configuration changes fails with Batch remediation failed on all target hosts with 'ClusterUUID' MethodFault in Host Profiles

book

Article ID: 454402

calendar_today

Updated On:

Products

VMware vSAN

Issue/Introduction

When standardizing cluster configurations, attaching and remediating a Host Profile extracted from a host in one vSAN cluster (e.g., running ESXi 9.1.0) onto a second target cluster managed by the same vCenter Server (e.g., running ESXi 9.1.1.0 patch build) with changes to vSAN configuration:

  • The batch remediation task fails on all target hosts in the cluster with a generic vmodl.MethodFault / vim.fault.HostConfigFailed.
  • The vSphere Client UI displays a non-descriptive error summary:
    • Error: 'ClusterUUID'. with no actionable details.
  • Per-host applyHostConfig tasks complete with haTask Status error.

This issue is seen only if there is a delta in vSAN configurations while applying host profiles.

 

 

Symptoms:

Diagnostic Evidence in Logs:

  • VMkernel log (/var/run/log/vmkernel.log):
    VmkAccess: VsiCheckAccess:68: python: running in hostprofilesDom(68): Vsi node vsanutil: Access denied by vmkernel access control policyor
    VmkAccess: VsiCheckAccess:68: python: running in hostprofilesDom(68): Vsi node CMMDS_ADMIN: Access denied by vmkernel access control policy

  • Hostd log (/var/run/log/hostd.log):
    Task Completed: haTask--vim.profile.host.profileEngine.HostProfileManager.applyHostConfig Status error

Environment

VMware vSphere / vSAN

ESXi 9.1.1.0, ESXi 9.1.0.0, VMware vCenter Server 9.1.1.0

Cause

The issue occurs because the host setup tool is blocked by ESXi's security rules from making required vSAN configuration updates during host profile application.

 

 

Resolution

Broadcom Engineering has developed a fix that will be included in the upcoming release.


Workaround:
Any Non-vSAN changes can be applied by ensuring there is no delta in vSAN configuration.
For vSAN configuration, please use vSAN with vCenter Configuration Profiles or QuickStart wizard for configuring vSAN Cluster.