スーパーバイザー クラスタのアップグレードが「ServerFaultCode: A general system error occurred: vix error codes = (1, 0).」により完了しない
search cancel

スーパーバイザー クラスタのアップグレードが「ServerFaultCode: A general system error occurred: vix error codes = (1, 0).」により完了しない

book

Article ID: 454214

calendar_today

Updated On:

Products

VMware vSphere Kubernetes Service

Issue/Introduction

免責事項:これは英文の記事「Supervisor Cluster Upgrade Stalls with "ServerFaultCode: A general system error occurred: vix error codes = (1, 0)." (454213)」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。


  • スーパーバイザー クラスタのアップグレードが以下のエラーにより完了しません。

A general system error occurred: vix error codes = (1, 0)

  • /var/log/vmware/wcp/wcpsvc.log に以下のようなエラーメッセージが繰り返し出力されて数時間経過しても Supervisor Control Plane VM の構成が完了しません。

    YYYY-MM-DDTHH:MM:SS.###Z error wcp [vclib/guestop_manager.go:54] [opID=########-########-####-####-####-############-vm-<ID>] Guest operation failed with err ServerFaultCode: A general system error occurred: vix error codes = (1, 0).

    YYYY-MM-DDTHH:MM:SS.###Z info wcp [vclib/guestop_manager.go:57] [opID=########-########-####-####-####-############-vm-<ID>] Guest operation failure is not retriable.
    YYYY-MM-DDTHH:MM:SS.###Z error wcp [kubelifecycle/kubenodeconfig.go:166] [opID=########-########-####-####-####-############-vm-<ID>] Failed to get kubenode VM VirtualMachine:vm-##### configuration status. Err ServerFaultCode: A general system error occurred: vix error codes = (1, 0).

    YYYY-MM-DDTHH:MM:SS.###Z error wcp [kubelifecycle/master_node_bootstrap.go:179] [opID=########-########-####-####-####-############-vm-<ID>] Failed to get guest configuration status. err API call to VMware vCenter Server (vpxd) failed. Details 'ServerFaultCode: A general system error occurred: vix error codes = (1, 0).
    '
    Note: vm-<ID> 部分が影響を受ける Supervisor Control Plane VM の vmid になります。

Environment

vSphere Kubernetes Service

vSphere Supervisor

Resolution

vix error codes = (1, 0).」を解決するには、影響を受ける Supervisor Control Plane VM 上の vmtoolsd サービスを再起動してください。

  1. SSH 経由で root ユーザーとして、vCenter Server Appliance (VCSA) にログインします。
  2. 以下のスクリプトを実行して、Supervisor Control Plane VM の root パスワードを取得します。

    /usr/lib/vmware-wcp/decryptK8Pwd.py

  3. 影響を受ける Supervisor Control Plane VM が配置されている ESXi ホストの Host Client にログインします。
  4. 左端ナビゲータで 仮想マシン を選択します。
  5. 影響を受ける Supervisor Control Plane VM を見つけて、仮想マシン コンソールを開きます。
  6. 手順 2. で取得したパスワードを使用して、root ユーザーとしてゲスト OS にログインします。
  7. 以下のコマンドを実行して、vmtoolsd サービスを再起動します。

    systemctl restart vmtoolsd

  8. /var/log/vmware/wcp/wcpsvc.log に出力されていた 「vix error codes = (1, 0).」エラーの出力が停止し、vSphere Client よりアップグレードが再開されていることを確認します。

Note: 「vix error codes = (1, 0).」エラーを解決した後でも、KB 382941 に記載されている別の問題が原因でアップグレードが停止したままになる場合があります。
その場合は、上記の記事を参照してください。

Additional Information