After upgrading a Data Aggregator (DA) the DA dadaemon service fails to stay running.
When reviewing the $DA_HOME/IMDataAggregatordata/logs/netops-data-aggregator.log file after running the "systemctl start dadaemon" command we see it try to start. It quickly fails with the following error.
2026-08-29T10:25:29,475 | INFO | main | DataAggregator | framework.boot.StartupInfoLogger 53 | - - | | Starting DataAggregator v25.4.9.9 using Java 17.0.19 with PID 27001 ($DA_HOME/IMDataAggregator/data-aggregator.main.jar started by root in $DA_HOME/IMDataAggregator)
2026-08-29T10:25:29,487 | INFO | main | DataAggregator | framework.boot.SpringApplication 652 | - - | | No active profile set, falling back to 1 default profile: "default"
2026-08-29T10:25:34,658 | WARN | main | rvletWebServerApplicationContext | pport.AbstractApplicationContext 636 | - - | | Exception encountered during context initialization - cancelling refresh attempt: org.springframework.context.ApplicationContextException: Unable to start web server
2026-08-29T10:25:34,680 | INFO | main | ConditionEvaluationReportLogger | .ConditionEvaluationReportLogger 82 | - - | |
Error starting ApplicationContext. To display the condition evaluation report re-run your application with 'debug' enabled.
2026-08-29T10:25:34,717 | ERROR | main | SpringApplication | framework.boot.SpringApplication 857 | - - | | Application run failed
org.springframework.context.ApplicationContextException: Unable to start web server
...
Caused by: java.lang.IllegalStateException: Unable to create trust store: Could not load store from '$DA_HOME/IMDataAggregator/config/ssl/truststore'
...
Caused by: java.lang.IllegalStateException: Could not load store from '$DA_HOME/IMDataAggregator/config/ssl/truststore'
...
Caused by: java.io.IOException: keystore password was incorrect
...
Caused by: java.security.UnrecoverableKeyException: failed to decrypt safe contents entry: javax.crypto.BadPaddingException: Given final block not properly padded. Such issues can arise if a bad key is used during decryption.
DX NetOps Performance Management Data Aggregator with HTTPS enabled
The app.SSL_TRUSTSTORE_PASSWORD variable is missing or incorrectly set in the application.properties file post-upgrade.
/opt/IMDataAggregator/config/application.properties in a text editor.app.SSL_TRUSTSTORE_PASSWORD variable.app.SSL_KEYSTORE_PASSWORD or the correct truststore password.dadaemon service using systemctl restart dadaemon.