Cloud Proxy deployment fails with an error code 'LCMVSPHERESYSTEM1000055'due to Read timed out
search cancel

Cloud Proxy deployment fails with an error code 'LCMVSPHERESYSTEM1000055'due to Read timed out

book

Article ID: 454172

calendar_today

Updated On:

Products

VMware SDDC Manager / VCF Installer

Issue/Introduction

  • During VCF installation, cloud proxy deployment fails as its associated ovf files couldn't be saved in destination datastore due to connectivity issue. VCF Operations UI Task progress shows an error code that reads, 'LCMVSPHERESYSTEM1000055' with cause as Read timed out". 

/var/log/vrlcm/vmware_vrlcm.log

YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.v.u.CoreUtility]  -- Found the cluster in the Datacenter
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- Host ESX-FQDN has some alarms or configuration issues with a red status.Checking next one for the datastore
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- Host ESX-FQDN has some alarms or configuration issues with a red status.Checking next one for the datastore
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- Creating Import result
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- DeployOptionsMOR{dataCenter=ManagedObjectReference: type = Datacenter, value = datacenter-3, serverGuid = nullresoursePool=ManagedObjectReference: type = ResourcePool, value = resgroup-11, serverGuid = null, dataStore=ManagedObjectReference: type
 = Datastore, value = datastore-16, serverGuid = null, host=null, cluster=ManagedObjectReference: type = ClusterComputeResource, value = domain-c10, serverGuid = null, destNetwork=[ManagedObjectReference: type = DistributedVirtualPortgroup, value = dvportgroup-##, serverGuid = null], vaName='CloudProxy-Name', diskFormat='thin', locale='', deployOption='smallunifiedcp', sourceLocation='null', version='9.0.2.0', productId='vrops', folder=ManagedObjectReference: type = Folder, value = group-v4, serverGuid = null}
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- creating import params
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.p.c.v.t.DeployOvfTask]  -- Resource pool::Resources
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.p.c.v.t.DeployOvfTask]  -- {"name":null,"description":null,"vcServerUrl":"vCenter-FQDN/sdk","vcServerUsername":"service account fqdn","vcServerPassword":"JXJXJXJX"}
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- Importing OVf
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- ##########################################################
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- OvfFileItem
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- chunkSize: null
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- create: false
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- deviceId: /CloudProxy-Name/ParaVirtualSCSIController0:0
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- path: Operations-Cloud-Proxy-9.0.2.0.25137840-system.vmdk
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- size: 565183488
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- ##########################################################
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- ##########################################################
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- OvfFileItem
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- chunkSize: null
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- create: false
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- deviceId: /CloudProxy-Name/ParaVirtualSCSIController0:1
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- path: Operations-Cloud-Proxy-9.0.2.0.25137840-data.vmdk
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- size: 7890944
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- ##########################################################
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- ##########################################################
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- OvfFileItem
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- chunkSize: null
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- create: false
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- deviceId: /CloudProxy-Name/ParaVirtualSCSIController0:2
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- path: Operations-Cloud-Proxy-9.0.2.0.25137840-cloud-components.vmdk
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- size: 2390202368
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- ##########################################################
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- ##########################################################
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- OvfFileItem
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- chunkSize: null
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- create: false
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- deviceId: /CloudProxy-Name/ParaVirtualSCSIController0:3
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- path: Operations-Cloud-Proxy-9.0.2.0.25137840-unified.vmdk
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- size: 7890944
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.d.v.d.i.BaseOvfDeploy]  -- ##########################################################
YYYY-MM-DDTHH:MIN:SEC ERROR vrlcm[#####] [pool-3-thread-74] [c.v.v.l.p.c.v.t.DeployOvfTask]  -- Error while uploading vmdks to vCenterError :{}
com.vmware.vim.vmomi.client.exception.ConnectionException: vCenter-FQDN/sdk/vimService invocation failed with "java.net.SocketTimeoutException: Read timed out"
YYYY-MM-DDTHH:MIN:SEC INFO vrlcm[#####] [pool-3-thread-74] [c.v.v.l.p.a.s.Task]  -- Injecting task failure event. Error Code : 'LCMVSPHERESYSTEM1000055', Retry : 'true', Causing Properties : '{ CAUSE ::  }'
com.vmware.vim.vmomi.client.exception.ConnectionException: https://vCenterFQDN/sdk/vimService invocation failed with "java.net.SocketTimeoutException: Read timed out"

  • vCenter Datastore UI shows status under Datastore Connectivity column as 'Not Connected'

Environment

VCF 9

Cause

The vmknic binded to the datatore experienced connectivity issue. By addressing the network connectivity issue, the datastore status flipped to 'Connected' state.

Resolution

Datastore Connectivity status is dependant on the underlying network backing iSCSI or NFS datastore. Follow below mentioned steps to resolve the issue. 

  1. Check Network connectivity
    1. Verify physical and virtual switch configurations for the iSCSI network.
    2. Ensure the ESXi host can ping the storage array IP address using vmkping from the ESXi Shell: vmkping -I vmkX <storage_ip> (replace vmkX with your iSCSI port group interface).
    3. Check that MTU settings (such as Jumbo Frames 9000) match end-to-end across the physical switches, vSwitch, and port groups.

  2. Rescan Storage Adapters
    1. Log into the vSphere Client or ESXi host client.
    2. Go to Storage > Adapters, select your iSCSI software adapter, and click Rescan.
    3. Verify if the targets and LUN devices populate under the adapter's devices list.

Additional Information

Troubleshooting ESXi connectivity to iSCSI arrays using software initiators