Tanzu Hub Deployment Fails when Availability Zone Name Contains Spaces
search cancel

Tanzu Hub Deployment Fails when Availability Zone Name Contains Spaces

book

Article ID: 454170

calendar_today

Updated On:

Products

VMware Tanzu Platform Core VMware Tanzu Platform - Hub

Issue/Introduction

During the installation or upgrade of the VMware Tanzu Hub tile, the BOSH deployment fails during the "apply changes" phase. Logs indicate that the deployment fails across multiple instances (including kubeletkafka, and others), preventing the services from starting successfully.

Cause

The deployment failure is caused by an Availability Zone (AZ) name that contains spaces. Tanzu Hub relies on underlying Kubernetes configurations that do not support spaces in AZ identifiers. This is a known limitation when deploying the Tanzu Hub tile in environments where the BOSH Availability Zone configuration includes whitespace.

Resolution

You must provide an Availability Zone for Hub whose name does not contain spaces.

  1. Create a new Availability Zone: Configure a new Availability Zone in your BOSH/vSphere infrastructure that is named without any spaces (e.g., "DevAZ" instead of "Dev AZ").
  2. Remove Hub Tile: Navigate to the Tanzu Hub tile configuration in Ops Manager. Click the Trash icon to remove the tile; Apply Changes.
  3. Add Hub tile again, using the new AZ: Update the deployment settings to use the newly created Availability Zone whose name lacks whitespace.
  4. Redeploy: Apply Changes to redeploy the tile.

Additional Information

Please ensure that all future Tanzu Hub deployments are planned using Availability Zone names that strictly avoid special characters and whitespace. This limitation is required to ensure compatibility with Kubernetes naming conventions used by the platform.