Unable to add a rebuilt ESXi host to a vSAN cluster due to residual vSAN partitions – VMware vSAN
search cancel

Unable to add a rebuilt ESXi host to a vSAN cluster due to residual vSAN partitions – VMware vSAN

book

Article ID: 454125

calendar_today

Updated On:

Products

VMware vSphere ESXi VMware vSAN

Issue/Introduction

 When attempting to add a fully rebuilt or repurposed ESXi host to a vSAN cluster, the operation fails with a "General system error." Specifically, the error message indicates a failure during the vSAN cluster join process, often referencing a "Sysinfo operation" or a failure to join the host in the vSAN cluster.

Symptoms can include one or multiple of the following: 

  • The ESXi host was previously part of a different vSAN cluster.
  • The host has been fully rebuilt (reinstalled OS).
  • Attempting to add the host to a new vSAN cluster fails with:
    • “A general system error occurred: Failed to join the host in vSAN cluster: Unable to complete Sysinfo operation.”
    • “Sysinfo error: Failure.”
  • esxcli vsan cluster get may still show unexpected or stale cluster configuration or membership information despite the host being "rebuilt."

 

Environment

vSAN (All) 

Cause

Even after a full OS reinstallation, residual vSAN metadata or partition information can persist on the local disks or the ESXi configuration layer. This leftover data causes the host to report itself as still belonging to or being "vSAN enabled" or has a disk format version for the previous cluster, which conflicts with the new cluster's configuration during the join operation.

Resolution

 To resolve this issue, the residual vSAN configuration must be explicitly cleared from the host before it is added to the new cluster.

  1. Verify vSAN Configuration: Connect to the ESXi host via SSH and run: esxcli vsan cluster get Note: If the output shows enabled vSAN clustering or lists a Sub-Cluster UUID, the host will need to be removed from the stale cluster

    1.  Force the host to leave its perceived vSAN cluster state: esxcli vsan cluster leave

  2. Check for Residual Partitions (If applicable): If the issue persists, use partedUtil to inspect disks for legacy vSAN partitions that may not have been fully erased during the rebuild by checking the disk partitions through vCenter UI

    1. navigate to the ESXi host.

    2. Click the Configure tab.

    3. Under Storage, click Storage Devices.

    4. Select a disk that was used for vSAN and Click Partition Details 
    5. If there are Partitions listed use the Erase Partitions option at the top of the Storage Devices list.
      Verify that the partition information you are erasing is not critical, and click OK to confirm your change. Repeat for all required disks.
      If there is an error when attempting to erase the partition, the host may need to be rebooted to clear any locks and Erase Partitions should be done before any other operations are attempted
  3. Re-attempt Cluster Join: After verifying the host is no longer in a cluster and has no vSAN partitions proceed to add the host to the new vSAN cluster via the vSphere Client.