When attempting to set a CPU reservation on VM's in an Allocation Model VDC the task fails with the following error message:Virtual machine reservation or limit or shares settings are invalid: [max allowed cpu reservation = 0 MHz, provided cpu reservation = XXXX MHz].
VMware Cloud Director 10.6.X
VMware Cloud Director 10.5.X
In the Allocation Pool model, a specific percentage of CPU and memory is guaranteed at the Organization Virtual Data Center (OrgVDC) level, rather than at the individual VM level. VMware Cloud Director achieves this by applying the reservation directly to the parent resource pool in vCenter.
To set CPU reservations on individual VMs, you must change the allocation model from Allocation Pool to Flex. This change can be made using an API request, as outlined in the following knowledge base article:
How to Change the Allocation Model of an Organization Virtual Data Center (OVDC) in VMware Cloud Director (VCD)