Clarity Advance Reporting Jaspersoft - Please wait message disappears when report run in same session by changing the parameter
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Clarity Advance Reporting Jaspersoft - Please wait message disappears when report run in same session by changing the parameter

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Article ID: 4541

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

CA PPM Advance Reporting Jaspersoft - Please wait message disappears when report run in same session by changing the parameter

Steps to Reproduce: 

1. Run a report with around 10 parameters click on apply
2. Report will start generating the data in the report with a message Please wait till it fetches the data on the 1st page
3. Change the filters by selecting more or reducing the data  and then click on apply button to generate the data

Expected Result: The message 'Please wait' should be there until report loads the data

Actual Result: The message 'Please wait' disappears and you will see at the report header "Cancel loading data"  . This means the report is still loading at the background

 

 

 

Environment

CA PPM 14.2 & above

Cause

This is a Jaspersoft defect  DE30551 and its fixed in Jaspersoft Patch 5.2.1.3 Jaspersoft Patches for CA PPM

 

Resolution

  1.  Please wait for the data to load and there will be a lag
  2. Once a report is run and you want to run report with different parameter, go back to repository and folder and re run the report. 

Attachments

1558699883588000004541_sktwi1f5rjvs16ou9.png get_app