vCenter Server upgrade from 7.x to 8.x fails during firstboot with Content Library Service error: "column cl.subscriptionsslcertificate does not exist"
search cancel

vCenter Server upgrade from 7.x to 8.x fails during firstboot with Content Library Service error: "column cl.subscriptionsslcertificate does not exist"

book

Article ID: 454023

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • The vCenter Server upgrade from version 7.x to 8.x fails during the firstboot phase while attempting to start the Content Library Service.
  • The upgrade process fails on the Installer UI during "Stage 2: Set up target vCenter Server and start services" at 92% completion. 

 

  • The following exception is logged in /var/log/firstboot/content-library-firstboot.py_<PID>_stderr.log :

Exception in thread "main" org.postgresql.util.PSQLException: ERROR: column cl.subscriptionsslcertificate does not exist
...
Command: ['/usr/java/jre-vmware/bin/java', '-Dvcde.cfg.dir=/etc/vmware-content-library', '-Dvcde.log.dir=/var/log/vmware/content-library', '-cp', '/usr/lib/vmware-content-library/install_lib/cls-upgrade.jar:/usr/lib/vmware-content-library/install_lib/dbutil.jar', 'com.vmware.cl.unified.upgrade.ClsUpgrade', '-c', '/etc/vmware-vpx/vcdb.java.properties', '/usr/lib/vmware-content-library/support/scripts/db/PostgreSQL/cls_unified', '-o', '/usr/lib/vmware-content-library/support/scripts/db/PostgreSQL/cls_unified/order60.cfg']
Stderr: Picked up JAVA_TOOL_OPTIONS: -Xms32M -Xmx128M -Dcom.sun.org.apache.xml.internal.security.ignoreLineBreaks=true -Dorg.apache.xml.security.ignoreLineBreaks=true

Environment

vCenter Server

Cause

This issue occurs because the subscriptionsslcertificate column is missing from the cl_library table in the source vCenter Server's PostgreSQL database (VCDB). The Content Library upgrade script in vCenter 8.x expects this column to exist and fails to initialize when it is missing.

Resolution

Resolving this issue requires manual modification of the vCenter Server PostgreSQL database.
To resolve this issue, please contact Broadcom Support and reference this Knowledge Base article.