Identity Portal connector to Identity Manager fails to start with exception 'java.lang.IllegalArgumentException'
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Identity Portal connector to Identity Manager fails to start with exception 'java.lang.IllegalArgumentException'

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Article ID: 45394

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal

Issue/Introduction

Issue: 

After installing Identity Portal and creating a connector to Identity Manager, the connector fails and the application server log shows an exception concerning 

'java.lang.IllegalArgumentException'

Environment:  

Identity Suite 12.6.7

Identity Portal 1.6.1

Cause: 

The cause could be that the public alias of the  environment is not set.

In such a case the exception will look similar to this:

ERROR [com.idmlogic.sigma.connector.ca.CaimAdapter] (http-/127.0.0.1:8080-3) Reload connector failed : java.lang.RuntimeException: java.lang.IllegalArgumentException: ErrorCode: 20026, ErrorFamily: GENERAL, Message: com.idmlogic.sigma.backend.BackendException: Failed initializing TEWS Client

at com.idmlogic.sigma.connector.ca.CaimAdapter.start(CaimAdapter.java:127) [sigma.connector.ca.im-0.0.2-SNAPSHOT.jar:]

at com.idmlogic.sigma.connector.ca.CaimAdapter.reload(CaimAdapter.java:182) [sigma.connector.ca.im-0.0.2-SNAPSHOT.jar:]

at com.idmlogic.sigma.manager.impl.AdapterManagerBean.reload(AdapterManagerBean.java:110) [sigma.bl-0.0.2-SNAPSHOT.jar:]

at com.idmlogic.sigma.manager.impl.ConnectorManagerBean.reload(ConnectorManagerBean.java:462) [sigma.bl-0.0.2-SNAPSHOT.jar:]

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [rt.jar:1.8.0_102]

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) [rt.jar:1.8.0_102]

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.8.0_102]

 

Environment

Release:
Component: SIGMA

Resolution

Log into the management console of Identity Manager

Access the environment your connector connects to

Set the 'Public Alias' and 'Public User' and save.

Restart environment.

Start the Identity Portal again