DSM 9.0.1 upgrade fails due to file permissions issue
search cancel

DSM 9.0.1 upgrade fails due to file permissions issue

book

Article ID: 453910

calendar_today

Updated On:

Products

VMware Data Services Manager

Issue/Introduction

  • Data Services Manaager pre-upgrade check for upgrade from version 9.0.1 to 9.0.2 or 9.1 fails with error:

    Unable to generate upgrade marker.

  • As a result, DSM upgrade fails to proceed.

Environment

VMware Data Services Manager 9.0.1

Cause

  • The pre-upgrade check fails if there are incorrect permisisons on specific DSM appliance files, to which access is needed during upgrade, e.g. file /data/vpgsql/pg_wal

  • /var/log/tdm/provider/providerupdatemanager.log reports logging similar to:

java.nio.file.AccessDeniedException: /data/vpgsql/pg_wal, thrown in update-manager-service (ProviderUpdateApplyService.findLatestWalFile) 

ERROR [er-update-job-4] f.s.ProviderUpdateApplyService - Max retries reached. Unable to generate upgrade marker.
ERROR [er-update-job-4] ProviderUpdateApplyStartAction - ProviderUpdateApplyStartAction__handleError {}
com.vmware.tdm.sp.common.exception.TdmException: Error generating upgrade marker file after retries. Generating upgrade marker file failed

Resolution

Please engage Broadcom Support.