The RTM_Inventory model (for Service Performance Manager - SPM) taking hours to activate in CA Spectrum.
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The RTM_Inventory model (for Service Performance Manager - SPM) taking hours to activate in CA Spectrum.

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Article ID: 45388

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Updated On:

Products

CA Spectrum

Issue/Introduction

The SpectroSERVER takes hours to activate all SSdb models even though the following have been set to true in the <SPECROOT>/SS/.vnmrc:

spm_wait_activate=yes

Allow_UpdAllSearches_Mode=true

Environment

Release: Any
Component:

Cause

The RTM_Inventory model is taking hours to activate due to having real time updates enabled for Global Collections and/or NCM device families.

Resolution

To determine if this is your problem you will need to add the following entry to the <SPECROOT>/SS/.vnmrc and stop/restart the SpectroSERVER:

mdlact_debug=true

If the SpectroSERVER does not stop because it is waiting on model activates, you may need to kill the SpectroSERVER process and reload your database.

When the SS starts up, the model activation will show you the model(s) that are taking a long time.  If the RTM_Inventory model is the only model and it's continuously having a problem, this applies to you.

You will need to let the model activation finish.  Once it completes, select the main "Global Collection" folder in the Explorer view of OneClick.  Click on the "List" tab in the Contents window.  Review the column labeled "Update Method". Edit the GC that are set to Real-Time to be periodic.