TCA-CP eventMesh status remains disconnected and VIM status shows "Unknown" after deployment
search cancel

TCA-CP eventMesh status remains disconnected and VIM status shows "Unknown" after deployment

book

Article ID: 453859

calendar_today

Updated On:

Products

VMware Telco Cloud Automation VMware Telco Cloud Platform

Issue/Introduction

  • Newly added vCenter instances remain in an Unknown VIM status despite showing as connected under endpoints.
  • The TCA-CP EventMesh status remains Disconnected while management and workload node status show Live.
  • Application and API logs (tca-mgr) reflect SSL Handshake and Duplicate URL exceptions:
 
ERROR c.v.tca.jwt.client.TcaCpClientImpl - Unable to execute request... 
Cause: javax.net.ssl.SSLHandshakeException: PKIX path building failed: 
sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
ERROR dispatcherServlet - Request processing failed: 
java.lang.IllegalArgumentException: TCA-CP url 'https://<FQDN>' is already in use by another TCA-CP

 

Environment

TCA 3.4

TCP 5.0

Cause

During deployment, the user configured TCA-CP appliances  with the External FQDN of the TCA Manager (TCA-M) appliance instead of their own unique FQDNs.
As Both TCA-CP appliances shared the manager's FQDN , cross-appliance HTTPS calls failed TLS path validation (SSLHandshakeException). Additionally, TCA Manager rejected duplicate registration attempts for an existing FQDN URL (IllegalArgumentException), preventing the EventMesh and VIM state machines from initializing.

Resolution

To resolve this issue, redeploy the TCA-CP appliances with their correct, unique FQDNs.