Install of Client Automation r14.*, MDB Failed with 1603
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Install of Client Automation r14.*, MDB Failed with 1603

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Article ID: 45385

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

Upgrade to r14.* fails with RC 1603 on database server.

Environment

Client Automation - All r14.* versions

Cause

Check the Installer log for a msg similar to this:


ERROR | MDB setup command error: <1> ERROR | Schema installation failed [7] CAUniITRM_Setup.rul - Line: 8207 - Launch ciCCSSetup.exe /f ""E:\insight\CAClientAutomation\WindowsProductFiles_x86\CCS\112_CCS\CCS"" /i 0 /ti ""SQLServer "" /pp ""E:\Program Files (x86)\CA\SC\ "" /ps ""E:\Program Files (x86)\CA\SC\ "" /n ""<SERVERNAME>"" /w """" /mn ""mdb"" /ma ""ca_itrm"" /mp ""XXX"" /jre ""E:\Program Files (x86)\CA\SC\Mdb\Windows\jre"" /comp ""0"" /langid ""enu"" /oHome """" /tnsName """" /mdbStatus ""YES"" /mdbSize """" /sysu """" /sysp """" /mdbbase ""mdb"" /port ""1526"" /s. 1: 4-21-2016 - 14:20:00 - INFO - File: CAUniITRM_Setup.rul - Line: 8368 - ciCCSSetup.exe returned: 1603

Possibility is that the mdb folder under \ca\sc does not get recreated during install.

Resolution

Rename ...\ca\sc\mdb folder to ...\ca\sc\mdb.old and start the setup again.