Error "Node pool name is incorrect, no worker nodes can be found" while CNF instantiation
search cancel

Error "Node pool name is incorrect, no worker nodes can be found" while CNF instantiation

book

Article ID: 453849

calendar_today

Updated On:

Products

VMware Telco Cloud Automation VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

 

  • Redeployment of the CNF (with updated software version) consistently fails on VMware Telco Cloud Automation (TCA).
  • The deployment fails specifically during the vRealize Orchestrator (vRO) "GRO-eth-customization" workflow.
  • The vRO workflow logs display the following error message:

Error! Node pool name is incorrect, no worker nodes can be found.

          Log Snippets :

####-##-## ##:##:##.## +## :## info INPU_DATA: { "config_data": { "gro": false, "node_pool_1": { "name": "###-########-######-####-###", "interfaces": [ { "name": "#####-####", "mtu": 2000 } ] }, } }

####-##-## ##:##:##.## +## :## error Error in (Workflow:GRO-eth-customization / Build GRO/GSO configuration (item1)#254) Error! Node pool name is incorrect, no worker nodes can be found.

 

 

Environment

 

  • TCA  : 3.x
  • vRO  : 8:xx

 

 

Cause

  • While the error message indicates a mismatch or syntax error with the node pool name, troubleshooting confirms that the CR templates are correct, the nodepool names match, and the worker nodes are in a "Ready state" with the appropriate labels applied.
  • The actual root cause of this failure is a connectivity issue between vRealize Orchestrator (vRO) and vCenter.
  • Because vRO cannot communicate with vCenter, the workflow is unable to successfully query the Kubernetes node status and labels. This results in the workflow returning an empty list of worker nodes, triggering the strict label query to fail and output the misleading "Node pool name is incorrect" error.

Resolution

To resolve this issue, you must restore communication between vRO and vCenter.

  1. Log in to the vRealize Orchestrator (vRO) environment.

  2. Test and validate network connectivity (ping, port checks) from vRO to the target vCenter server.

  3. Ensure that the vCenter endpoint plugin inside vRO is properly configured, authenticated, and showing as "Connected" or "Alive".

  4. Resolve any underlying network routing, firewall, or authentication issues blocking the connection.

  5. Ensure to update the vCenter password is updated in vRO, if there were any vCenter passwords that had been changed.

  6. Once connectivity between vRO and vCenter is successfully restored, retry the CNF instantiation/redeployment from TCA.