Migrating VMs from old NFS storage to new one fails with error "The operation is not supported on the object"
search cancel

Migrating VMs from old NFS storage to new one fails with error "The operation is not supported on the object"

book

Article ID: 453845

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms :

  • While migrating VMs from old NFS to new NFS storage following error is observed:

    The operation is not supported on the object.

    Changing or applying VM Storage Policies with Data Service capabilities during migrate operations is disallowed. VM Storage Policies with Data Service capabilites can be assigned to the provisioned VM after the migrate operation has been completed and before the VM has been powered on.

  • vCenter server logs (vpxd.log) reports the target datastore inaccessible:

    YYYY-MM-DDTHH:MM:SS.###Z exror vpxd[#####] [Oziginatoz@6876 sub=HostPicker opID=########] Couldn't find any candidate host that satiafies all constraints

    YYYY-MM-DDTHH:MM:SS.###Z warning vpxd[#####) [Originator@6876 sub-Vmomi opID-########] VMOMI activation LRO failed; << ########-####-####-####-############, <TCP '#.#.#.#: ####'>, <TCP '#.#.#.# : #####'>>, CatalogSyncManager, vim.vslm.vcenter.CatalogSyncManager.queryCatalogChange, <vim. version.v8_0_3_0, internal, 8.0.3.0>, (null) >, N3VimSFault21InaccessibleDatastore9ExceptionE(Fault cause: vim.fault.InaccessibleDatastore

    YYYY-MM-DDTHH:MM:SS.###Z error vpxd[#####] [Originator@6876 sub=Default opID=########] [VpxLRO]-ERROR session[#########-####-####-####-############] ########-####-####-####-#############-- ########-####-####-####-############# (########-####-####-####-#############) -- CatalogSyncHanager -- vim.valm.voenter.CatalogSyncManager.queryCatalogChange: :vim.fault. InaccessibleDatastore

    --> Result:
    --> (vim.fault.InaccessibleDatastore) {
    --> faultCause = (vmodl.MethodFault) null,
    --> faultMessage m <unset>,
    --> datastore = 'vim.Datastore:########-####-####-####-#############:datastore-###',
    --> name = "<datastore_name>",
    --> detail = "notAccessible"
    --> msg = ""

Environment

  • vSphere ESXi 8.x

  • vSphere vCenter 8.x

Cause

Storage policy configured for VMs use tags and these tags are further used to encrypt VM disks. Trying to migrate to new NFS datastore fails to use same storage policy as it shows up as not supported. This results in failing migration.


(from /var/log/vmware/vmware-vpx/vpxd.log)

YYYY-MM-DDTHH:MM:SS.###Z warning vpxd[4145768] [Originator@6876 sub=Vmomi opID-########-########-####-#####-##:########-##] VMOMI activation LRO failed; << ########-####-####-####-######[229d, <TCP '#.#.#.# : ####'>, <TCP '#.#.#.#. : ####'>>, StoxageResourceManagez, vim.StozageResourceManager.applyRecommendation, <vim. version. v8_0 3 0, internal, 8,0.3.0>, (null) >, N5Vmomi5Fault12NotSuppozted9ExceptionE (Fault cause:vmodl.fault.NotSupported
-- >)
-- > [context]zkq7AVECAQAAAPONbgEZdnB4ZAAAowFTbG11dmihY29y255zbwAA/gdCABCvQwCMiUoBhakXbG1idmlvbWkuc28AAcgYJ4LkySIBdnB4ZACCdMV/AoIJVjQCghd56wGCCRVzAoLmL3MCg3/qMwFsaWJ2aN0tdl1w2XMuc28AgjEVggIBTXUcgmjvXwKCsXCAAoL7sIACgu/DEwKC3pqAAgAE3DcAFzU4
ALv/UASwjgBsaWJwdGhyZWFkLnNvLjAABe/6D2xpYmMuc28uNgA=[/context]
2026-08-11T07:04:50.4082 info vpxd[4145768] [Originator@6876 sub=vpxLzo opID-########-########-####-#####-##:########-##] [VpxLRO] -- FINISH task-2383905

YYYY-MM-DDTHH:MM:SS.###Z exror vpxd[4145768] [Originatoz@6876 aub-Default opID-########-########-####-#####-##:########-##:########-##] [VpxLRO] -- ERROR task-2383905 -- ########-####-####-####-############(#########-####-####-####-##############) -- StorageResourceManager -- vim.StorageResourceManager. applyRecommendation: :vmodl.fault.NotSupported
--> Result:
--> (vmodl.fault.NotSupported) (
-->     faultCause = (vmodl.Methodlault) null,
-->     faultMessage = (vmodl.LocalizableMessage) [
-->           (vmod1. LocalizableMessage) (
-->                 key = "com.vmware.vim.vpxd.iofilter.policyChangeDisallowed",
-->                 arg - (vmodl. KeyAnyValue) [
-->                        (vmod1. KeyAnyValue) I
-->                               key = "operation"

Resolution

  1. Uncheck 'Enable tag based placement rules' on VM storage policy used by virtual machines.