Administrators are unable to perform vSphere operations on NSX-T Manager Virtual Machines. The "Migrate" option is grayed out within the vCenter Server.
When we try to drag and drop the NSX-T VM , we see below error.
TCP 5.x
vCenter 7.x
NSX-T 3.2
This error is due to the NSX VM being managed by the NSX Solution.
This is by default to ensure that users do not accidentally modify these service VMs.
In order to migrate the NSX-T VMs, access to the MOB is required to enable the RelocateVM_Task method
https://ExamplevCenterFQDNorIP/ui/#?extensionId=vsphere.core.vm.summary&objectId=urn:vmomi:VirtualMachine:vm-52:########-####-####-####-3445fc35c5ba&navigator=vsphere.core.viTree.hostsAndClustersViewhttps://[vCenter FQDN/IP]/mob/?moid=AuthorizationManager&method=enableMethodsentity filed as below
<!-- array start --><entity type="ManagedEntity" xsi:type="ManagedObjectReference">vm-52</entity><!-- array end -->
method filed
<method>RelocateVM_Task</method>
https://[vCenter FQDN/IP]/mob/?moid=AuthorizationManager&method=disableMethods