Migrate option is greyed out for NSX-T VMs
search cancel

Migrate option is greyed out for NSX-T VMs

book

Article ID: 453827

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Administrators are unable to perform vSphere operations on NSX-T Manager Virtual Machines. The "Migrate" option is grayed out within the vCenter Server.

When we try to drag and drop the NSX-T VM , we see below error.

Environment

TCP 5.x

vCenter 7.x

NSX-T 3.2

Cause

This error is due to the NSX VM being managed by the NSX Solution.
This is by default to ensure that users do not accidentally modify these service VMs.

Resolution

In order to migrate the NSX-T VMs, access to the MOB is required to enable the RelocateVM_Task method

  1. First, gather the MoRef ID for the VMs that are having the issue.
      • For an individual VM using vSphere client: 
      • Open a web browser to the vCenter Server's Flex (Flash) or vSphere Client (HTML5)
      • In the left hand side inventory, select the affected VM's object
      • With the VM selected and highlighted, in the URL bar, review the string and look for "VirtualMachine:vm-xx"
        Example:
        https://ExamplevCenterFQDNorIP/ui/#?extensionId=vsphere.core.vm.summary&objectId=urn:vmomi:VirtualMachine:vm-52:########-####-####-####-3445fc35c5ba&navigator=vsphere.core.viTree.hostsAndClustersView
        • In this example VM's MOB ID is vm-52.
  2. Once the MoRef IDs are found, you can go to the below URL logging in with [email protected] and password in order to start making the changes:
        https://[vCenter FQDN/IP]/mob/?moid=AuthorizationManager&method=enableMethods
  3. There will be two fields that need to be modified in order to allow the VM to be changed:
        • entity filed as below

          <!-- array start -->
          <entity type="ManagedEntity" xsi:type="ManagedObjectReference">vm-52</entity>
          <!-- array end -->

          method filed

          <method>RelocateVM_Task</method>

  4. These should match exactly and the MoRef ID will need to be filled in for that VM. Leave sourceId blank and click "Invoke Method"
  5. Go back to the vSphere Client and you should see that the VM "Migrate" is now available
    • Once all the VMs in concern have been modified, you will now need to disable the ability to migrate those VMs:
  6. Go to the following URL:
    •   https://[vCenter FQDN/IP]/mob/?moid=AuthorizationManager&method=disableMethods
  7. Fill the details same as from step 3. The sourceId can be a random 4 digit number [ eg.1234]  as what is in the field doesn't matter but is required to have the filed populated to disable the edit ability of the VM.
  8. Click "Invoke Method" and the returned output should state 'void'
       You should then see that the VMs are no longer able to be migrate