Online Backup OLB Fault-Tolerant Database Synchronization Failure due to non-empty "Backup Main LS Port" SCP entry field
search cancel

Online Backup OLB Fault-Tolerant Database Synchronization Failure due to non-empty "Backup Main LS Port" SCP entry field

book

Article ID: 4538

calendar_today

Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

The Fault-Tolerant Database Synchronization does not launch after an OnLine Backup of Main Location Server.

This problem is only observed on the MLS pair (primary and secondary) in a DSS environment.

Environment

CA Spectrum 9.x, 10.x

Cause

There is a Location Server misconfiguration. On the MLS (Main Location Server) primary and secondary servers, the "Backup Main LS Host" and the "Backup Main LS Port" fields cannot be filled in.

 

Resolution

The "Backup Main LS Host" and the "Backup Main LS Port" fields in the Location Server configuration must be empty in the Main Location Server (MLS) SpectroSERVER configurations only. The Location Server code keeps track of the SpectroSERVERs and by the precedence values knows which SpectroSERVER is the backup.  Clear these settings.  Once the changes are saved, the Location Server needs to be restarted.


Then you may need to reload the SSdb database on the secondary MLS host.


../SS-Tools/SSdbload -il -add precedence savefile



Location_Server_restart.png

Supply the Backup Main LS Host and Port on the others DSS (Distributed SpectroSERVERs), on both primary and secondary servers. The primary and secondary (pair) servers must have the same entries in the Location Server Settings.



Additional Information

Please reference the "Establishing Fault Tolerance" section of the documentation for more information.

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/spectrum/10-4/administrating/distributed-spectroserver-administration/establish-fault-tolerance.html
https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/spectrum/10-3-2/administrating/distributed-spectroserver-administration/establish-fault-tolerance.html

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/spectrum/10-3-1/administrating/distributed-spectroserver-administration/establish-fault-tolerance.html

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/spectrum/10-3/administrating/distributed-spectroserver-administration/establish-fault-tolerance.html

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/spectrum/10-2/administrating/distributed-spectroserver-administration/establish-fault-tolerance.html

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/spectrum/9-4-4/administrating/distributed-spectroserver-administration/establish-fault-tolerance.html

Attachments

1558691904569000004538_sktwi1f5rjvs16gr4.png get_app
1558691902758000004538_sktwi1f5rjvs16gr3.png get_app
1558691899907000004538_sktwi1f5rjvs16gr2.png get_app