VCF Automation 9.1 Fails to Connect to NSX with 403 Error for VMApp Orgs VCF Automation
search cancel

VCF Automation 9.1 Fails to Connect to NSX with 403 Error for VMApp Orgs VCF Automation

book

Article ID: 453756

calendar_today

Updated On:

Products

VCF Automation

Issue/Introduction

Users attempting to integrate NSX with VCF Automation 9.1 for VMApp Organizations may encounter an "Unauthorized (403)" error when performing network operations or creating cloud accounts. This article outlines the known architectural limitation and provides the necessary workarounds.

  • Unauthorized (403) error when when trying to connect to NSX from VCF Automation in Connections.
  • "Forbidden: Error occurred in the backing network provider: The credentials were incorrect or the account specified has been locked., error code 403"
  • Affects VMApp Organization environments.

Environment

VCF Automation 9.1

Cause

This issue is caused by an architectural limitation in VCF Automation 9.1 regarding service account support for VMApp Orgs. The necessary integration components to support service accounts in this specific configuration are not present in the 9.1 release.

Resolution

Support for this configuration will be added in a future VCF Automation release. In the interim, please utilize one of the following workarounds:

  1. Use an NSX local admin account for the VCF Automation integration.
  2. Add the VCF Automation IP addresses to the NSX lockout immune list to prevent account lockout.