creating an external connection (Provider Gateway) to a VRF in VCF Automation, the operation fails with the following error message: "Redistribution type TIER0_EVPN_TEP_IP is not supported on VRF tier-0 /infra/tier-0
search cancel

creating an external connection (Provider Gateway) to a VRF in VCF Automation, the operation fails with the following error message: "Redistribution type TIER0_EVPN_TEP_IP is not supported on VRF tier-0 /infra/tier-0

book

Article ID: 453725

calendar_today

Updated On:

Products

VCF Automation

Issue/Introduction

When attempting to create an external connection (Provider Gateway) to a VRF in VCF Automation, the operation fails with the following error message:

"Redistribution type TIER0_EVPN_TEP_IP is not supported on VRF tier-0 /infra/tier-0s/<router_name>."

This issue prevents the successful onboarding of tenants that require external connectivity.

Environment

vCF Automation 9.1

Cause

The failure occurs because VCF Automation incorrectly triggers a default Route Redistribution rule (TIER0_EVPN_TEP_IP) during the Provider Gateway creation phase. This specific redistribution type is not supported on VRF Tier-0 gateways in the NSX environment.

Resolution

A resolution for the issue is planned for vCF Automation 9.2 release.

To workaround this issue, manually adjust the route redistribution configuration in NSX Manager:

  1. Log in to the NSX Manager.
  2. Navigate to the affected VRF.
  3. Locate the Route Re-distribution rule.
  4. Edit the rule under advertised tier-1 and deselect the "IPSec Local Endpoint" checkbox.
  5. Save the configuration.
  6. Return to VCF Automation and retry the Provider Gateway creation process.

Recreating the Provider Gateway in VCFA should now succeed.