When extending the virtual disk of a database instance in VMware Data Services Manager (DSM) 2.2, the operation may remain stuck in an "InProgress" state. This occurs when the vsphere-csi-controller pod on the workload cluster encounters a state synchronization deadlock, preventing the re-configuration directive from reaching vCenter Server.
vsphere-csi-controller pod contain the following error: "Failed to get the task of CNS QuerySnapshots with err: ServerFaultCode: NotAuthenticated"The vsphere-csi-controller pod experiences a stale cache or hung control-plane lock, preventing API calls from dispatching to vCenter.
The CSI controller pod will need to be deleted and reprovisioned open a Support case with VMware by Broadcom for assistance.