A vSphere Lifecycle Manager (vLCM) compliance scan fails, and the vCenter Server reports the host status as "Unknown." The task fails with the error message: "A failure occurred when starting a host compliance check operation on host : Error: com.vmware.vapi.std.errors.not_allowed_in_current_state Messages: com.vmware.esx.task.contention".
Symptoms
VMware vSphere ESXi 8.0 and later
VMware vCenter Server 8.0 and later
A stale compliance scan process is stuck in the local ESXi host lifecycle database. vCenter incorrectly believes a scan operation is already in progress, preventing new compliance tasks from initiating.
Perform the following steps on the affected ESXi host: