Failed to allocate vtep label for TransportNode when applying Transport Node Profile
search cancel

Failed to allocate vtep label for TransportNode when applying Transport Node Profile

book

Article ID: 453672

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • When applying a Transport Node Profile (TNP) to a new or existing cluster in VMware NSX, the operation fails with the following error:

Failed to allocate vtep label for TransportNode. Please check logs for error received from IDAS

  • Below NSX manager logs under /var/log/proton/nsxapi.log are observed.

[Timestamp] ERROR L2HostConfigTaskExecutor2 VtepPopulatorUtil 6068 FABRIC [nsx@6876 comp="nsx-manager" errorCode="MP8205" level="ERROR" subcomp="manager"] Failed to get a valid Vtep label.
com.vmware.nsx.platform.idas.exception.IdasException: [IDAS0] Pool ########-####-####-####-############ has no free ids.
 at com.vmware.nsx.platform.idas.lib.service.RangeServiceImpl$AllocationTask.call(RangeServiceImpl.java:1316) ~[?:?]
 at com.vmware.nsx.platform.idas.lib.service.RangeServiceImpl$AllocationTask.call(RangeServiceImpl.java:1266) ~[?:?]
 at java.util.concurrent.FutureTask.run(Unknown Source) ~[?:?]
 at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) ~[?:?]
 at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) ~[?:?]
 at com.vmware.nsx.util.concurrent.Executors$MeteredRunnable.run(Executors.java:353) ~[nsx-util.jar:?]
 at java.lang.Thread.run(Unknown Source) ~[?:?]
[Timestamp] ERROR L2HostConfigTaskExecutor2 TransportNodeAsyncServiceImpl 6068 FABRIC [nsx@6876 comp="nsx-manager" errorCode="MP8205" level="ERROR" subcomp="manager"] Failed to send the HostConfig message. [TN=TransportNode/########-####-####-####-############]. Reason: Failed to allocate vtep label for TransportNode. Please check logs for error received from IDAS.
com.vmware.nsx.management.switching.common.exceptions.SwitchingException: null
 at com.vmware.nsx.management.switching.sync.host.VtepPopulatorUtil.allocateVtepLabel(VtepPopulatorUtil.java:292) ~[?:?]
 at com.vmware.nsx.management.switching.sync.host.VtepPopulator.allocateResourcesToNewVteps(VtepPopulator.java:414) ~[?:?]
 at com.vmware.nsx.management.switching.sync.host.VtepPopulator.populateVtepsForHostSwitch(VtepPopulator.java:264) ~[?:?]
 at com.vmware.nsx.management.switching.sync.host.VtepPopulator.populateVtepsForHostSwitch(VtepPopulator.java:226) ~[?:?]
 at com.vmware.nsx.management.switching.sync.host.VtepPopulator.populateVtepForUpdatedHostSwitches(VtepPopulator.java:119) ~[?:?]
 at com.vmware.nsx.management.switching.sync.host.TransportNodeAsyncServiceImpl.stageSendingHostConfigMsg(TransportNodeAsyncServiceImpl.java:1251) ~[?:?]
 at com.vmware.nsx.management.switching.sync.host.TransportNodeAsyncServiceImpl.syncTransportNode(TransportNodeAsyncServiceImpl.java:3223) ~[?:?]

  • No allocated_ids are seen from the The API output GET https://<NSX-MANAGER-IP>/api/v1/pools/vtep-label-pools 
    {
        "results": [
            {
                "pool_usage": {
                    "total_ids": 131071,
                    "allocated_ids": 0, <<<<
                    "free_ids": 131071
                },
                "ranges": [
                    {
                        "start": 1,
                        "end": 131071
                    }
                ],

 

 

Environment

VMware NSX 4.x

VMware NSX-T Data Center 3.x

 

Resolution

For resolution, collect NSX managers support bundle and associated Transport Node (ESXi host or Edge) support bundle.

Open a support request with Broadcom Support