When launching the Ghost Solution Suite (GSS) console, the error "Unable to connect to the Symantec Ghost Solution Suite DB Management Service. Please make sure this service has been started and is running correctly" appears. This indicates that the service is either stopped, unable to authenticate, or unable to communicate with the SQL database.
Port 505 is blocked or unavailable.
The Ghost Solution Suite, as per our documentation TCP/UDP ports required in Ghost Solution Suite 3.X, port 505 over the TCP protocol needs to available. If your SQL database is not located on your Ghost Solution Suite server, the port required is 1433.
To confirm, you can run the following PowerShell command:
Get-NetTCPConnection -LocalPort 505 -ErrorAction SilentlyContinue | Select-Object LocalAddress, LocalPort, StateIf the command returns an error, the port is not available and you should work with your server administrator or network team to make it available.
If the command returns nothing, that means the Altiris Deployment Server DB Management service is not running. You should start the service and try again.
Otherwise, the command should return something that looks like the following:
Some other items to check in addition, are as follows:
Check Windows Event Viewer:
Altiris Deployment Server DB Management service.Verify SQL Authentication:
eXpress SQL database with db_owner permissions.Restart Services: