Users are unable to log in to their CloudHealth account via SAML SSO. The login process fails with an error message stating that the user is not assigned to any role.
Check and make sure that The identity provider (IDP) is passing the required "roles" attribute in the SAML assertion.
CloudHealth requires this attribute to map the user to a specific CloudHealth role during the authentication process.
To resolve this, configure your IDP to include the roles attribute in the SAML assertion. The value passed should correspond to the user's access level:
Example from an Assertion sent by IDP that includes the Roles attribute needed by CloudHealth
Reference: For detailed configuration steps, please refer to the CloudHealth documentation for enabling SAML SSO for Classic Organizations.