Unable to authenticate against controller at localhost:9991: Authentication failed: all available authentication mechanisms failed:
JBOSS-LOCAL-USER: javax.security.sasl.SaslException: ELY05128: Failed to read challenge file [Caused by java.io.FileNotFoundException: /opt/CA/wildfly-portal/standalone/
tmp/auth/local1260804661234553644.challenge (Permission denied)] DIGEST-MD5: javax.security.sasl.SaslException: DIGEST-MD5: Server rejected authentication
The default configuration file (jboss-cli.xml) defaulted to port 9990, which handled the traffic. These routes are isolated to specific management ports (9991 for IP and 9992 for IG). If you run the command without specifying the controller port, the CLI defaults back to 9990 and attempts to connect to the wrong instance, which triggers the authentication error and permission error seen.
For Identity Portal (IP)
Similarly, navigate to the bin directory for the Governance component first.