VAMI backup fails at 98% with the error: "BackupManager encountered an exception. See logs for details".
search cancel

VAMI backup fails at 98% with the error: "BackupManager encountered an exception. See logs for details".

book

Article ID: 453507

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • The VAMI backup fails with a generic error at 98% completion .
  • The /var/log/vmware/applmgmt/backup.log contains the following error

    ERROR: BackupManager encountered an exception: File contains no section headers. file: '/etc/systemd/network/10-eth0.network', line: 1 'B\n'

Environment

  • VMware vCenter Server Appliance 8.x

Cause

The network configuration file /etc/systemd/network/10-eth0.network has been incorrectly modified, often containing invalid stray characters before than required [Match] and [Network] sections.

Resolution

To resume backups, follow these steps:

Take a snapshot of the VCSA before performing any changes. Refer Snapshot Best practices for vCenter Server Virtual Machines

  • Log in to the vCenter Server Appliance via SSH.
  • Verify if there are any stray characters or empty lines at the beginning of the 10-eth0.network file
    • cat /etc/systemd/network/10-eth0.network 
  • Create a backup copy of the file before editing
    • cp /etc/systemd/network/10-eth0.network /etc/systemd/network/10-eth0.network.bak
  • Navigate to the network directory and edit the file using vi editor.
    • cd /etc/systemd/network/
    • vi 10-eth0.network
    • Remove any corrupted text and replace it with the following structure:

      [Match]
      Name=eth0

      [Network]
      Address=####.####.####.####/##
      Gateway=####.####.####.####
      DNS=####.####.####.####

      Note: The #### represents the current IP, Gateway, and DNS information for the environment. Do not alter these existing values.

    • Save and exit (:wq!).
  • Verify the interface status: ip addr show eth0