VMware vCenter Server 9.x
This issue is observed in vCenter 9.1 GA and caused by the vSphere Client incorrectly handles locale data when the browser language does not match the internally supported languages.
This results in functional failures or permission errors.
This issue is scheduled to be resolved in the vCenter 9.1.2.0 patch release.
Workaround:
To mitigate the immediate issue, users can explicitly set their language preference in the vSphere Client:
The vSphere Client interface will now correctly load the necessary locale data, and functionality should be restored.