Error: "Failed to unregister vCenter Server 'vcenter-name'. Hosts from this vCenter Server are still referenced" when unregistering vCenter from VCF Automation
search cancel

Error: "Failed to unregister vCenter Server 'vcenter-name'. Hosts from this vCenter Server are still referenced" when unregistering vCenter from VCF Automation

book

Article ID: 453428

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • Unable to Unregister a vCenter Server from VCF Automation when following: Deactivate and Unregister a vCenter Instance in VCF Automation
  • When trying to Unregister a vCenter Server from VCF Automation, the following error is displayed:
    [ ########-####-####-####-############ ] Failed to unregister vCenter Server "<vcenter-name>". Hosts from this vCenter Server are still referenced. Here are the first 1 out of 1: [<esxi-name>].

Environment

VCF Automation 9.0.x

Cause

This issue occurs when the the vCenter has been removed from VCF, but there were still hosts associated with it in Automation. As a result, VCFA retains references to associated resources.

Resolution

Database modification is required to resolve the issue. Contact Broadcom Support and note this Article ID (453428) in the problem description. For more information, see Creating and managing Broadcom cases