Upgrading ESX hosts fails with precheck error "The current vCenter is not licensed by a license server"
search cancel

Upgrading ESX hosts fails with precheck error "The current vCenter is not licensed by a license server"

book

Article ID: 453417

calendar_today

Updated On:

Products

VMware SDDC Manager / VCF Installer

Issue/Introduction

  • Attempting to run prechecks for an ESX upgrade on VCF 9.1 fails with error "The current vCenter is not licensed by a license server
  • Upon checking the license page > Update licenses > License Servers tab shows the license server status as "Not Registered

Environment

VMware Cloud Foundation 9.1 

VMware ESX 

 

Resolution

  1. Delete the license server following: Delete a License Server
  2. Redeploy a new license server ova to set up and connect to the Business Service Console and VCF Operations via : Register VCF Operations and Your License Server in Connected Mode
  3. Retry the ESX prechecks and proceed with the upgrade. 

Additional Information

Upon connecting back the new license server if the following error is received "Usage report overdue by <date_in_past" example: "Usage report overdue by Feb 15, 2026" and the license mode is connected, the following may need to be complete to resolve: 

  • Change the license server mode from connected to disconnected mode and generate a new usage file to put in the business service console. This will generate a new license file to be uploaded into VCF Operations. This is documented in Report License Usage and Update Licenses in Disconnected Mode. Then change the license server mode back to connected mode.