VCF Usage Meter is Inaccessible After Upgrade to 9.1
search cancel

VCF Usage Meter is Inaccessible After Upgrade to 9.1

book

Article ID: 453410

calendar_today

Updated On:

Products

VMware Usage Meter

Issue/Introduction

After upgrading to VCF Usage Meter 9.1, the appliance web interface is no longer accessible.
 
When reviewing the dss_error.log(/opt/vmware/cloudusagemetering/platform/log/dss_error.log)
 
The following error message is observed, indicating a failure to authenticate the platform client:
ERROR --- [gateway_Runner] com.vmware.um.gw.GW : Cannot start platform client, journaling will be disabled.
com.vmware.um.common.err.UmException: Unable to login [401]: {"error":"invalid_client"}

Environment

VCF Usage Meter 9.1.x

Cause

This issue is caused by incorrect file ownership permissions for the .passwd file located in the /opt/vmware/cloudusagemetering/platform/security/ directory.
 
For the appliance to function properly, the .passwd file must be owned by the login-service user. However, due to a permission mismatch, it is incorrectly owned by the usagemeter user. This prevents the login service from reading the necessary credentials, leading to the invalid_client error.
 
Output of the ls -al command demonstrating the incorrect file ownership:
usagemeter@test$ ls -al /opt/vmware/cloudusagemetering/platform/security/
total 400
-r-------- 1 usagemeter usagemeter ### ### ## ####.passwd
-rw-rw-r-- 1 usagemeter usagemeter ##### ### ### ##:##cacerts
-rw-r----- 1 usagemeter usagemeter #### ### ## ##:##keystore
-rw-r--r-- 1 login-service login-service #### ### ## ##:##sign-keystore


Resolution

To resolve the issue:

  • Change the ownership of .passwd to login-service by running the below command:                                      
     chown login-service:login-service /opt/vmware/cloudusagemetering/platform/security/.passwd
  • Reboot the Usage Meter appliance.