dss_error.log(/opt/vmware/cloudusagemetering/platform/log/dss_error.log)ERROR --- [gateway_Runner] com.vmware.um.gw.GW : Cannot start platform client, journaling will be disabled.
com.vmware.um.common.err.UmException: Unable to login [401]: {"error":"invalid_client"}.passwd file located in the /opt/vmware/cloudusagemetering/platform/security/ directory..passwd file must be owned by the login-service user. However, due to a permission mismatch, it is incorrectly owned by the usagemeter user. This prevents the login service from reading the necessary credentials, leading to the invalid_client error.ls -al command demonstrating the incorrect file ownership:usagemeter@test$ ls -al /opt/vmware/cloudusagemetering/platform/security/total 400-r-------- 1 usagemeter usagemeter ### ### ## ####.passwd
-rw-rw-r-- 1 usagemeter usagemeter ##### ### ### ##:##cacerts
-rw-r----- 1 usagemeter usagemeter #### ### ## ##:##keystore
-rw-r--r-- 1 login-service login-service #### ### ## ##:##sign-keystoreTo resolve the issue:
.passwd to login-service by running the below command: chown login-service:login-service /opt/vmware/cloudusagemetering/platform/security/.passwd