YYYY-MM-DDTHH:MM:SS:sssZ <edge_name> NSX 2469204 FABRIC [nsx@6876 comp="nsx-edge" subcomp="datapathd" s2comp="intel-rte" level="WARN"] vmxnet3_process_events(): queue error event 0x2 for 00:50:56:##:##:##YYYY-MM-DDTHH:MM:SS:sssZ <edge_name> NSX 2469204 FABRIC [nsx@6876 comp="nsx-edge" subcomp="datapathd" s2comp="intel-rte" level="WARN"] vmxnet3_process_events(): tq 1 error 0x80000007YYYY-MM-DDTHH:MM:SS:sssZ <edge_name> NSX 2469204 FABRIC [nsx@6876 comp="nsx-edge" subcomp="datapathd" s2comp="phys-port" level="INFO"] reset dpdk callback for port 3YYYY-MM-DDTHH:MM:SS:sssZ <edge_name> NSX 2469204 FABRIC [nsx@6876 comp="nsx-edge" subcomp="datapathd" s2comp="intel-rte" level="INFO"] Posted mgmt lsn message mgmt: port 3 type DPDK_RESET..........YYYY-MM-DDTHH:MM:SS:sssZ <edge_name> NSX 2469204 FABRIC [nsx@6876 comp="nsx-edge" subcomp="datapathd" s2comp="intel-rte" level="WARN"] vmxnet3_process_events(): queue error event 0x2 for 00:50:56:##:##:##YYYY-MM-DDTHH:MM:SS:sssZ <edge_name> NSX 2469204 FABRIC [nsx@6876 comp="nsx-edge" subcomp="datapathd" s2comp="intel-rte" level="WARN"] vmxnet3_process_events(): tq 0 error 0x80000007YYYY-MM-DDTHH:MM:SS:sssZ <edge_name> NSX 2469204 FABRIC [nsx@6876 comp="nsx-edge" subcomp="datapathd" s2comp="phys-port" level="INFO"] reset dpdk callback for port 3YYYY-MM-DDTHH:MM:SS:sssZ <edge_name> NSX 2469204 FABRIC [nsx@6876 comp="nsx-edge" subcomp="datapathd" s2comp="intel-rte" level="INFO"] Posted mgmt lsn message mgmt: port 3 type DPDK_RESETNote: The preceding log excerpts are only examples. Date, time, port and queue numbers as well as other variables may vary depending on your environment.
VMware NSX
The issue is caused by the edge attempting to send a packet on an uplink with VLAN 0 and the Tx VLAN offload bit set in the packet metadata. The ESXi's ENS interface flags this as a fatal error, drops the packet, and causes the edge dataplane to reset the uplink device due to a "VMXNET3_ERR_TXD_INVALID (0x80000007)" error due to an invalid TX descriptor
Workaround
In the NSX Manager Change the Transport VLAN of the Edge Uplink profile (Overlay Edge Switch) associated with the affected Edge nodes from the Default Transport VLAN 0 to the explicitly required environment VLAN.
Kindly make sure the Uplink Mapping associated with NSX Edge VM is configured as Trunk VLAN port with required VLAN allowed instead of Access VLAN Port