Dynamic Capacity Intelligence (DCI) is running on two LPARs: LPAR1 and LPAR2
The production DCI Controller (started in ACTIVE MODE) is running on LPAR1, with agents running on LPAR1 and LPAR2.
A test DCI Controller (running in SIMULATION MODE) is started from time to time, for example to test new PTFs before applying them on production, on LPAR2 with their own agents on LPAR1 and LPAR2.
The two LPARs are not connected in SYSPLEX, each one has its own USS file system.
The zFS files for the two DCI environments are separate too:
Since the USS file systems are separate too, the same mountpoint name is used for production and test, for example /####/dci
However, when the production agent is active on LPAR2, the test DCI filesystem cannot be unmounted, since the UNMOUNT command receives the following error message:
BPXF137E RETURN CODE 00000072, REASON CODE 058801AB. THE UNMOUNT FAILED FOR FILE SYSTEM hlq.DCI.TEST.ZFS.
If the production agent on LPAR2 is shut down, the test DCI filesystem can be successfully unmounted.
DCI 2.0 systems running on the same LPARs
Per IBM documentation:
A DCI agent does not access directly any USS directory, so the problem is not related to DCI but seems to be on IBM side.
A quick workaround is to use different mountpoint directories: