ERROR: "Domain not configured" while accessing a Workload Domain
search cancel

ERROR: "Domain not configured" while accessing a Workload Domain

book

Article ID: 453287

calendar_today

Updated On:

Products

VCF Operations

Issue/Introduction

  • When accessing a workload domain via Fleet Management > Lifecycle, you receive the below error:
Domain not configured
Please configure the domain to use this capability
  • The VCF adapter is configured and collecting data. 
  • The error persists even after restarting the data collection of the VCF Adapter

Environment

VCF Operations 9.0.1

VCF Operations 9.1.0

Cause

This issue is caused by a synchronization mismatch between the SDDC Manager and VCF Operations. Deleting a domain from SDDC manager instead of via VCF Operations can lead to this mismatch.

Resolution

To resolve this synchronization mismatch, remove the affected workload domain from the VCF adapter to trigger a clean re-detection and re-mapping cycle:

  1. In the VCF Operations UI, navigate to Administration Integrations.

  2. Locate the vCenter adapter instance associated with the affected workload domain.

  3. Stop data collection for the adapter.

  4. Remove the affected workload domain vCenter adapter instance from the VCF adapter configuration.

    • Note: Do not select the "Delete related objects" option.

  5. Save the configuration changes.

  6. Wait for 5 to 10 minutes for the collection cycle to complete. The VCF adapter will automatically detect and re-add the workload domain.

  7. Verify that the workload domain is mapped correctly as a child of the VMware Cloud Foundation adapter.

  8. Navigate to Fleet Management > Lifecycle to confirm the "Domain not configured" error is resolved and the domain is visible.