"Domain not configured" error while accessing Workload Domain in VCF Operations
search cancel

"Domain not configured" error while accessing Workload Domain in VCF Operations

book

Article ID: 453287

calendar_today

Updated On:

Products

VCF Operations

Issue/Introduction

This article provides a resolution for the "Domain not configured" error observed when accessing workload domains within the VCF Operations Fleet Management UI.

Symptoms:

  • When accessing a workload domain via Fleet Management > Lifecycle, you receive the below error:
Domain not configured
Please configure the domain to use this capability
  • The VCF adapter is configured and collecting data. 
  • The error persists even after restarting the data collection of the VCF Adapter

Environment

VCF Operations 9.0.x

Cause

This issue is caused by a synchronization mismatch between the SDDC Manager and VCF Operations.

Resolution

To resolve this synchronization mismatch, remove the affected workload domain from the VCF adapter to trigger a clean re-detection and re-mapping cycle:

  1. In the VCF Operations UI, navigate to Administration Integrations.

  2. Locate the vCenter adapter instance associated with the affected workload domain.

  3. Stop data collection for the adapter.

  4. Remove the affected workload domain vCenter adapter instance from the VCF adapter configuration.

    • Note: Do not select the "Delete related objects" option.

  5. Save the configuration changes.

  6. Wait for 5 to 10 minutes for the collection cycle to complete. The VCF adapter will automatically detect and re-add the workload domain.

  7. Verify that the workload domain is mapped correctly as a child of the VMware Cloud Foundation adapter.

  8. Navigate to Fleet Management > Lifecycle to confirm the "Domain not configured" error is resolved and the domain is visible.