Timed out error importing new ISOs in VMware Cloud Director
search cancel

Timed out error importing new ISOs in VMware Cloud Director

book

Article ID: 453237

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Attempting to upload an ISO into VMware Cloud Director (VCD) results in an error similar to the following:

    com.vmware.vcloud.api.presentation.service.TimedoutException: Timed out. at com.vmware.vcloud.fabric.transfer.impl.ReceivingSocketImpl$FileImportResourceFuture.isDone(ReceivingSocketImpl.java:138)

  • Smaller uploads work without issue.
  • Uploads from the internal network complete successfully.
  • In the logs (/opt/vmware/vcloud-director/logs/vcloud-container-debug.log), the upload session is constructed successfully, as in the following example:

    2026-08-04 17:43:18,742 | DEBUG    | pool-jetty-41             | TransferSessionImpl            | Created transfer session spooling directory VfsFile[fileObject=file:///opt/vmware/vcloud-director/data/transfer/########-####-####-####-############] | requestId=########-####-####-####-############,request=POST https://###.###.###/api/catalog/########-####-####-####-############/action/upload,requestTime=1785865398169,remoteAddress=##.##.##.##:#####,userAgent=...,accept=application/*+xml;version 40.0.0-alpha
    2026-08-04 17:43:18,751 | DEBUG    | pool-jetty-41             | TransferSessionImpl            | Created new transfer session urn:uuid:########-####-####-####-############, spool dir VfsFile[fileObject=file:///opt/vmware/vcloud-director/data/transfer/########-####-####-####-############] | requestId=########-####-####-####-############,request=POST https://###.###.###/api/catalog########-####-####-####-############/action/upload,requestTime=1785865398169,remoteAddress=##.##.##.##:#####,userAgent=...,accept=application/*+xml;version 40.0.0-alpha
    2026-08-04 17:43:18,761 | DEBUG    | pool-jetty-41             | TransferService                | Created resource file [resource file:file,,,############,file:///opt/vmware/vcloud-director/data/transfer/########-####-####-####-############,0,null] | requestId=########-####-####-####-############,request=POST https://###.###.###/api/catalog/########-####-####-####-############/action/upload,requestTime=1785865398169,remoteAddress=##.##.##.##:#####,userAgent=...,accept=application/*+xml;version 40.0.0-alpha
    2026-08-04 17:43:19,009 | INFO     | pool-jetty-41             | VAlcServiceImpl                | [valc] Creating Media backing from transfer session urn:uuid:########-####-####-####-############. mediaId=urn:uuid:########-####-####-####-############, storageProfiles=[urn:uuid:########-####-####-####-############], fetchContent=true, legacyStorageProfile=null | requestId=########-####-####-####-############,request=POST https://###.###.###/api/catalog/########-####-####-####-############/action/upload,requestTime=1785865398169,remoteAddress=##.##.##.##:#####,userAgent=...,accept=application/*+xml;version 40.0.0-alpha
    ...

  • Data is transferred for a period of time, similar to the following example:

    2026-08-04 17:43:21,333 | DEBUG    | auto-pool-Monitor Service-22-thread-3 | ReceivingSocketImpl            | Resource file not fully transferred yet (0/5,055,336,448) for transfer session ########-####-####-####-############ |
    ...
    2026-08-04 17:46:42,330 | DEBUG    | auto-pool-Monitor Service-22-thread-3 | ReceivingSocketImpl            | Resource file not fully transferred yet (52,428,800/5,055,336,448) for transfer session ########-####-####-####-############ |
    ...

  • At some point, the transfer of data stalls and then experiences an error after the configured idle session timeout elapses, similar to the entry below:

    2026-08-04 19:49:54,863 | DEBUG    | auto-pool-TransferService-17-thread-1 | TransferService                | Updating transfer session urn:uuid:########-####-####-####-############ |
    2026-08-04 19:49:54,864 | DEBUG    | auto-pool-TransferService-17-thread-1 | TransferSessionImpl            | Session urn:uuid:########-####-####-####-############ is unchanged, skipping DB update |
    2026-08-04 19:49:55,329 | ERROR    | auto-pool-Monitor Service-22-thread-3 | ReceivingSocketImpl            | Transfer session ########-####-####-####-############ no longer exists (timed out) |

Environment

VMware Cloud Director 10.6.x

Cause

VMware Cloud Director (VCD) is accepting data during the upload, but data stops being delivered due to an external restriction. VCD then terminates the session after the period without activity reaches the idle session timeout.

Resolution

In order to remediate this issue, review the network path to determine the external factor limiting the amount of data transferred.