NetOps 25.4.11 DA or DC sslConfig.sh script fails to import PKCS12 keystore files
search cancel

NetOps 25.4.11 DA or DC sslConfig.sh script fails to import PKCS12 keystore files

book

Article ID: 453219

calendar_today

Updated On:

Products

Network Observability CA Performance Management

Issue/Introduction

While using NetOps Performance Management: Data Aggregator or Data Collector's sslConfig.sh script to import a PKCS12 format keystore file (.pfx or .p12), you will run into an issue which after entering in all of the correct information:

ERROR: unable to parse private key.

Environment

NetOps PM 25.4.11

Cause

Introduced in PM 25.4.11, there is a missing line in the sslConfig.sh script.

Resolution

  1. Use vi or nano to edit your DA or DC sslConfig.sh script.
  2. Find the line in the script which contains:  KEY_LOCATION="${CF_P12FILENAME}"
  3. Add a new line under that line and enter in the missing line: KEY_FILETYPE="PKCS12"
  4. Save the file and run the script again.

This will be resolved in NetOps 25.4.12.