Hosts display in evaluation mode despite having sufficient license capacity (for example, a total core count of 224, with 128 displaying as licensed and 96 displaying as evaluation).
The following error message displays in the UI: Licenses could not be synchronized with vCenters
Stale license usage entries from hosts upgraded from ESX 8.x to 9.x are not removed automatically and consume licenses, even though they do not report as using a license in VCF Operations. This prevents the upgraded hosts from receiving the correct license, forcing them into evaluation mode.
To identify this cause:
Log in to VCF Operations.
Navigate to Manage > Licensing > Licenses & Registration > Manage > License Servers.
Select the relevant License Server.
Click the arrow next to a vCenter with a Primary license.
In the right pane, review the Licensed Assets page. The Asset Licenses Status for the affected host(s) displays "Removed" under the selected vCenter, and the Host Version displays "Pre-Version 9" despite being upgraded to 9.x.
Follow these steps in order to resolve the issue:
From the Licensed Assets page, select the affected host(s) and select RECLAIM USED CAPACITY.
Wait 10 minutes and check the licensing status.
If the license fails to reclaim, navigate to VCF Operations > Manage > Licensing > Licenses & Registration.
Select a vCenter under vCenter Systems.
Under Assets, select the hosts currently in Evaluation mode.
Select Assign an Override License.
Select a license with sufficient capacity and click Assign.