vCenter VAMI Backup to SMB Share Fails with NT_STATUS_TRUSTED_RELATIONSHIP_FAILURE
book
Article ID: 453142
calendar_today
Updated On:
Products
VMware vCenter Server
Issue/Introduction
This article provides a resolution for file-based backup failures in vCenter Server when using an SMB target share. If the backup fails with an NT_STATUS_TRUSTED_RELATIONSHIP_FAILURE error, it typically indicates that the SMB server is not correctly joined to the Active Directory domain.
When running the following command, it errors out with "session setup failed: NT_STATUS_TRUSTED_RELATIONSHIP_FAILURE": smbclient //<SMB_SERVER_IP_OR_FQDN>/<SHARE_NAME> -U "DOMAIN\username"
Environment
VMware vCenter Server 8.x
VMware vCenter Server 9.x
Cause
The backup failure occurs because the SMB file server is not part of the Active Directory domain, resulting in a trust relationship failure during the authentication process.
Theapplmgmtlogs [/var/log/vmware/applmgmt/applmgmt.log] exhibit the following error: ERROR:plugins.SMBClientStorageIOLib:Command failed with error: NT_STATUS_TRUSTED_RELATIONSHIP_FAILURE
Resolution
Verify SMB Domain Connectivity: Attempt to log in to the SMB server using domain credentials results in the error, "The trust relationship between this workstation and the primary domain failed," confirms that the server is not correctly joined to the domain or the trust is broken.
Join the SMB file server to the Active Directory domain to establish a valid trust relationship.
Test the connectivity from the vCenter Server command line using the smbclient utility to ensure authentication is successful by running the following command: smbclient //<SMB_SERVER_IP_OR_FQDN>/<SHARE_NAME> -U "DOMAIN\username"
Retry the backup from the vCenter Server Appliance Management Interface (VAMI) at port 5480.