Error: 400 (bad_request) during SCDF service creation in Tanzu RabbitMQ
search cancel

Error: 400 (bad_request) during SCDF service creation in Tanzu RabbitMQ

book

Article ID: 453029

calendar_today

Updated On:

Products

VMware Tanzu Platform Core VMware Tanzu RabbitMQ VMware Tanzu Application Service

Issue/Introduction

  • Creation of a brokered Spring Cloud Data Flow (SCDF) service instance fails with a validation error. This occurs after an upgrade to RabbitMQ tile 10.x, which upgrades RabbitMQ version to 4.x.
  • Service provisioning fails with the following error:

    CF-ServiceBrokerBadResponse(10001): Service broker error: Error 400 (bad_request): Validation failed [{<<"ha-mode">>,<<"exactly">>}, {<<"ha-params">>,2}, {<<"ha-sync-mode">>,<<"automatic">>}] are not recognised policy settings

  • More detailed logs can be viewed by running cf commands from the system org and p-dataflow space on the associated p-dataflow app:

    cf target -o system -s p-dataflow
    cf apps
    cf logs p-dataflow-1.14.15        ###-----> this app name may differ in your environment

Environment

VMware Tanzu Application Service (EAR) 10.x 

VMware Tanzu RabbitMQ Tile 10.x

RabbitMQ 4.x

Spring Cloud Data Flow (SCDF)

Cause

RabbitMQ 4.x deprecated Mirrored Standard Queues. Policies containing ha-modeha-params, or ha-sync-mode are no longer recognized and cause the RMQ cluster to reject the creation of new brokered instances. See the Release Notes for detailed breaking changes.

Resolution

To resolve this issue, remove the deprecated policy settings from the RabbitMQ tile:

  1. Log in to Ops Manager.
  2. Navigate to the VMware Tanzu RabbitMQ tile.
  3. Select Pre-Provisioned RabbitMQ.
  4. Locate the Policy for new instances field.
  5. Remove the following keys and their values from the configuration:
    • ha-mode
    • ha-params
    • ha-sync-mode
  6. Click Save.
  7. Return to the Ops Manager Installation Dashboard and click Apply Changes.

 

Additional Information

For further assistance, see Contact Support. Scroll to the bottom of the page and click on the respective region.