Attempting to deploy Aria products using Aria Suite Lifecycle Ui > Lifecycle Operations > Create Environment > Enter details and Product Info having selected Any product > Run Prechecks : Prechecks fail for "Hostname Resolvability Check" fails with error "Hostname '<hostname>' does not resolve to the Ip Address <ip_address>.'" and "IP Address resolvability check" fails with error "IP address '<ip_address>' does not resolve to the Hostname <hostname>."
The vmware_vrlcm.log showed error message "Executing command : nslookup ; <hostname/ip_address> ; <dns_server_ip>" "DNS output: ;; connection timed out; no servers could be reached"
Environment
Aria Suite Lifecycle 8.18.x
Aria Operations 8.18.x
Aria Automation 8.18.x
Aria Operations for Logs 8.18.x
Aria Operations for Networks 6.14.x
VMware Identity Manager 3.3.7
Cause
This issue occurs due to an incorrect or unreachable DNS server configuration on the Aria Suite Lifecycle appliance.
Resolution
To resolve this issue, validate and correct the DNS settings on the appliance:
Validate the DNS server(s) configured in the Aria Suite Lifecycle UI. Note the IP address.
Run the following command to test resolvability using the specific dns server:
nslookup <ip_address/hostname> <dns_server_ip>
If either of the above commands fail, validate the forward and reverse lookup records on your DNS server or add a functional DNS server to the Aria Suite Lifecycle configuration.
Once DNS resolution is successful via SSH, retry the prechecks in the UI.