Resolvability Precheck Failure during Product Deployment inAria Suite Lifecycle
search cancel

Resolvability Precheck Failure during Product Deployment inAria Suite Lifecycle

book

Article ID: 453009

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • Attempting to deploy Aria products using Aria Suite Lifecycle Ui > Lifecycle Operations > Create Environment > Enter details and Product Info having selected Any product > Run Prechecks : Prechecks fail for "Hostname Resolvability Check" fails with error "Hostname '<hostname>' does not resolve to the Ip Address <ip_address>.'" and "IP Address resolvability check" fails with error  "IP address '<ip_address>' does not resolve to the Hostname <hostname>."
  • The vmware_vrlcm.log showed error message
    "Executing command : nslookup ; <hostname/ip_address> ; <dns_server_ip>"
    "DNS output: ;; connection timed out; no servers could be reached"

Environment

  • Aria Suite Lifecycle 8.18.x
  • Aria Operations 8.18.x
  • Aria Automation 8.18.x
  • Aria Operations for Logs 8.18.x
  • Aria Operations for Networks 6.14.x
  • VMware Identity Manager 3.3.7

Cause

This issue occurs due to an incorrect or unreachable DNS server configuration on the Aria Suite Lifecycle appliance.

Resolution

To resolve this issue, validate and correct the DNS settings on the appliance:

  1. Validate the DNS server(s) configured in the Aria Suite Lifecycle UI. Note the IP address.
  2. SSH to the Aria Suite Lifecycle machine as root.
  3. Validate connectivity to the DNS server(s) using any of the standard supported methods, a few listed below:
    1. ping <dns_server_ip>
    2. telnet <dns_server_ip> 443   [or]   telnet <dns_server_ip> 53
    3. nc -zv <dns_server_ip> 443   [or]    nc -zv <dns_server_ip> 53
  4. Run the following command to test resolvability using the specific dns server:
    nslookup <ip_address/hostname> <dns_server_ip>
  5. If either of the above commands fail, validate the forward and reverse lookup records on your DNS server or add a functional DNS server to the Aria Suite Lifecycle configuration.
  6. Once DNS resolution is successful via SSH, retry the prechecks in the UI.