How to prevent that the Form customizations affect the Requests already opened

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Article ID: 4530

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Updated On:

Products

CA Service Catalog CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

When a Form is customized/changed, that change are reflected in all Requests that uses that form, including the Requested opened previously. 

This means that, if customer add a reuired field in the form, all old Requests will have a new empty required field in that Form.

Cause

This happens because the Form for that Service got changed literally, in a sense, the Service won't use an "old" Form to display. 

Also, in Catalog system, it doesn't do versions control for the same Form.

 

 

 

Environment

Service Catalog 12.8, 12.9, 14.1

Resolution

When customers need to make an update to a form without affecting requests that have already been submitted, do the following in the Form Designer:

For this example, we will assume the name of the form that needs to be modified is "Form1". 

 

1. Create a new folder called "Retired Forms". 

2. Make a copy of "Form1". The new copy will be called "Copy of Form1". 

3. Rename "Form1" to "Form1 - yyyy/mm/dd" (replace yyyy/mm/dd with the current date). 

4. Move "Form1 - yyyy/mm/dd" to the "Retired Forms" folder. 

5. Rename "Copy of Form1" to "Form1". 

6. Update "Form1" as needed. 

7. Modify the Service Options, which are currently pointing to "Form1 - yyyy/mm/dd", so they point to the new "Form1". 

 

This way, all existing requests, will be referencing "Form1 - yyyy/mm/dd" and all new requests will reference "Form1".