Error Message : vmware-postgres-archiver service crashed while starting in VAMI.
search cancel

Error Message : vmware-postgres-archiver service crashed while starting in VAMI.

book

Article ID: 452995

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • file base backup is not working
  • vmware-postgres-archiver service is stopped with error in VAMI : "service crashed while starting"
  • /var/log/vmware/vpostgres/pg_archiver.log.stderr:
YYYY-MM-DDTHH:MM:SS ERROR  pg_archiver could not open directory "/storage/archive/vpostgres": No such file or directory
  • df -h show /storage/archive partition empty
/dev/mapper/archive_vg-archive               51282400        8  48644980   1% /storage/archive

Environment

vCenter 8u3

Cause

The issue is due to the /storage/archive/vposgres folder missing after being moved or deleted

Resolution

To Solve the issue, recreate the vpostgres folder as follow :

1 ) take snapshot/backup of vCenter : ( for link vCenter : https://knowledge.broadcom.com/external/article/313886/)

2) stop the archiver service

#vmon-cli --stop vmware-postgres-archiver

3) Create the folder with the correct permissions :

#cd /storage/archive
#mkdir vpostgres
#chown -R vpostgres:vpgmongrp vpostgres/
#chmod 700 vpostgres/

4) Search for replication_slot Removing the PG_Replication_Slot

#/opt/vmware/vpostgres/current/bin/psql -U postgres -d VCDB -c "select * from pg_replication_slots;"

if the command above does not return (0 rows), run the following :

#/opt/vmware/vpostgres/current/bin/psql -U postgres -d VCDB -c "select pg_drop_replication_slot('vpg_archiver');"

5) restart the archiver service 

#vmon-cli --start vmware-postgres-archiver

6) run file base backup again.